Packages

NodeDiagram packages.

Interface

Package

Version

node_diagram_int

0.1.0

Requirements

  • Ruby, v.2.6.5v. \geq 2.6.5

Dependencies

Development

Runtime

Changelog

v0.1.0, 2020-05-01
v0.1.0, 2020-05-01

Added

  • version.rb.

  • Gem Specification.

  • README.md.

  • 'require'd diagram_int.

  • Subclassed DiagramInt.

  • NodeDiagramInt.

  • NodeDiagramIntTest.

  • diagram_int dependency.

Edited

Fixed

  • test_helper.rb's 'require' node_diagram_int statement.

Installation

Rubygems hosts the node_diagram_int package. Declare the dependency attribute in the Gem Specification file, or declare the gem in the project's Gemfile:

Gemfile
Gem Specification
Gemfile
Gemfile
gem 'node_diagram_int', '~> 0'
Gem Specification
gem_name.gemspec
Gem::Specification.new do |spec|
# ...
spec.add_development_dependency 'node_diagram_int', '~> 0'
# Or
spec.add_runtime_dependency 'node_diagram_int', '~> 0'
# ...
end

Then, download and install the package.

$ bundle exec install

Bundler downloads and installs the package in the appropriate context.

'require'

Installation complete, place require 'node_diagram_int' in a relevant file.

Implementation

Package

Version

node_diagram_impl

1.0.0

Requirements

  • Ruby, v.  2.6.5.v.\ \geq\ 2.6.5.

Dependencies

Development

Run-time

Changelog

v1.0.0, 2020-06-06
v0.3.0, 2020-05-30
v0.2.0, 2020-05-18
v0.1.0, 2020-05-01
v1.0.0, 2020-06-06

Added

  • FUNDING.yml.

  • data_library, node_error, and diagram_factory_comp development dependencies.

Edited

  • Bumped diagram_comp dependency version and linked_list_comp dependency version.

  • Deleted integration tests.

Fixed

v0.3.0, 2020-05-30

Added

  • diagram_comp 'require'ment.

  • linked_list_comp dependency.

Edited

  • Updated development dependencies.

  • Deleted diagram 'require'ment.

  • Formatted.

Fixed

v0.2.0, 2020-05-18

Added

  • File tests.

Edited

  • Updated the node library dependency Major Version.

  • README.md's Installation section.

  • 'd()' is 'data()'.

Fixed

v0.1.0, 2020-05-01

Added

  • version.rb.

  • Gem Specification.

  • README.md.

  • 'require'd diagram.

  • NodeDiagram.

  • NodeDiagramTest.

  • Dependencies.

Edited

Fixed

Installation

Rubygems hosts the node_diagram_impl package. Declare the dependency attribute in the Gem Specification file, or declare the gem in the project's Gemfile:

Gemfile
Gem Specification
Gemfile
Gemfile
gem 'node_diagram_impl', '~> 1'
Gem Specification
gem_name.gemspec
Gem::Specification.new do |spec|
# ...
spec.add_development_dependency 'node_diagram_impl', '~> 1'
# Or
spec.add_runtime_dependency 'node_diagram_impl', '~> 1'
# ...
end

Then, download and install the package.

$ bundle exec install

Bundler downloads and installs the package in the appropriate context.

require

Installation complete, place require 'node_diagram_impl' in a relevant file.

Library

Package

Version

node_diagram

2.0.0

Requirements

  • Ruby, v.  2.6.5.v.\ \geq\ 2.6.5.

Dependencies

Development

Run-time

Changelog

v2.0.0, 2020-06-07
v1.0.1, 2020-05-21
v1.0.0, 2020-05-19
v0.1.0, 2020-05-01
v2.0.0, 2020-06-07

Added

  • diagram_comp, linked_list_comp, node_comp, data_library, node_error, and diagram_factory_comp development dependencies.

  • node_diagram_impl's integration tests.

  • FUNDING.yml.

Edited

  • Deleted node and diagram development dependencies.

  • Bumped node_diagram_impl's major version.

  • Reconfigured Travis CI.

Fixed

v1.0.1, 2020-05-21

Added

  • diagram and node development dependencies.

Edited

  • Deleted diagram and node runtime dependencies.

  • Deleted node and diagram 'require'ments.

Fixed

v1.0.0, 2020-05-19

Added

  • Test coverage.

Edited

  • node dependency. Bumped Major Version.

  • README.md's repository description, Installation text, and Documentation text.

Fixed

v0.1.0, 2020-05-01

Added

  • version.rb.

  • Gem Specification.

  • README.md.

  • 'require'd diagram, node, node_diagram_int, and node_diagram_impl.

  • Formatted NodeDiagramLibraryTest.

Edited

Fixed

  • 'require' statement in test_helper.rb.

Installation

Rubygems hosts the node_diagram package. Declare the dependency attribute in the Gem Specification file, or declare the gem in the project's Gemfile:

Gemfile
Gem Specification
Gemfile
Gemfile
gem 'node_diagram', '~> 2'
Gem Specification
gem_name.gemspec
Gem::Specification.new do |spec|
# ...
spec.add_development_dependency 'node_diagram', '~> 2'
# Or
spec.add_runtime_dependency 'node_diagram', '~> 2'
# ...
end

Then, download and install the package.

$ bundle exec install

Bundler downloads and installs the package in the appropriate context.

require

Installation complete, place require 'node_diagram' in a relevant file.