Packages

Interface

Package

Version

node_error_int

2.0.0

Requirements

  • Ruby, v.  2.6.5.\ v.\ \geq\ 2.6.5.

Dependencies

Development

  • bundler,  v.  2.1.\ v.\ \geq\ 2.1.

Runtime

Changelog

v2.0.0, 2020-05-28
v1.0.0, 2020-04-09
v0.1.0, 2020-03-17
v2.0.0, 2020-05-28

Added

  • Test coverage.

  • Added data_structure_error_int development dependency.

Edited

  • Updated source documentation.

  • Updated Gem Specification email, summary, description, and changelog_uri.

  • Rewrote README.md.

  • 'require'd data_structure_error_int.

  • Subclassed DataStructureErrorInt. Previously subclassed DataStructureError.

  • Deleted data_structure_error_library dependency.

Fixed

v1.0.0, 2020-04-09

Added

  • YARDocumentation.

  • Removed the node?(node = nil) method.

  • A file assertion.

  • GNU General Public License, Version 3.

  • A .yardopts file.

Edited

  • Test class file format.

  • Gem Specification.

  • README.md format.

Fixed

  • 'require' statements.

  • README.md Installation and Documentation URI links.

v0.1.0, 2020-03-17

Added

  • Project files.

  • Constants, methods, and method documentation.

  • Configuration files - travis, README, CODE_OF_CONDUCT, Changelog, LICENSE.txt, gem specification.

  • Tests, 100% coverage.

Edited

Fixed

Installation

Rubygems hosts the node_error_int package. Declare the package in the project's Gemfile, or, in the Gem Specification file:

Gemfile
Gem Specification
Gemfile
Gemfile
gem 'node_error_int', '~> 2'
Gem Specification
gem_name.gemspec
Gem::Specification.new do |spec|
# ...
# Development dependency.
spec.add_development_dependency 'node_error_int', '~> 2'
# Runtime dependency.
spec.add_runtime_dependency 'node_error_int', '~> 2'
# ...
end

Then, download and install the package:

$ bundle exec install

Bundler downloads and installs the package in the appropriate context.

require

Installation complete, insert require 'node_error_int' in a relevant file.

Implementation

Package

Version

node_error_impl

2.0.0

Requirements

  • Ruby, v.  2.6.5.\ v.\ \geq\ 2.6.5.

Dependencies

Development

Run-time

Changelog

v2.0.0, 2020-05-28
v1.0.0, 2020-04-09
v0.1.0, 2020-03-18
v2.0.0, 2020-05-28

Added

  • A default message.

  • Test coverage.

Edited

  • Deleted node_error_int 'require'ment.

  • Updated source documentation.

  • Updated Gem Specification's email, summary, description, changelog URI, and dependencies.

  • Rewrote README.md.

  • 'require'd data_structure_error_impl.

  • Subclassed DataStructureError.

Fixed

v1.0.0, 2020-04-09

Added

  • Removed NodeErrorHelper.

  • YARDocumentation.

  • TypeError message setter protection.

  • A .yardopts file.

Edited

  • Copyright statements.

  • node_error_impl.rb. Removed the node?(any_object = nil) method.

  • Test file. Rewrote.

  • Gem Specification.

Fixed

  • 'require' statements.

  • README.md's Installation and Documentation page links.

v0.1.0, 2020-03-18

Added

  • Configuration files.

  • Tests.

  • NodeError implementation code.

  • Documentation.

Edited

Fixed

Installation

Rubygems hosts the node_error_impl package. Declare the package in the project's Gemfile, or, in the Gem Specification file:

Gemfile
Gem Specification
Gemfile
Gemfile
gem 'node_error_impl', '~> 2'
Gem Specification
gem_name.gemspec
Gem::Specification.new do |spec|
# ...
# Development dependency.
spec.add_development_dependency 'node_error_impl', '~> 2'
# Runtime dependency.
spec.add_runtime_dependency 'node_error_impl', '~> 2'
# ...
end

Then, download and install the package:

$ bundle exec install

Bundler downloads and installs the package in the appropriate context.

require

Installation complete, insert require 'node_error_impl' in a relevant file.

Library

Package

Version

node_error

4.0.0

Requirements

  • Ruby, v.  2.6.5.\ v.\ \geq\ 2.6.5.

Dependencies

Development

  • bundler,  v.  2.1.\ v.\ \geq\ 2.1.

Run-time

Changelog

v4.0.0, 2020-05-28
v3.0.0, 2020-04-09
v2.0.0, 2020-03-18
v4.0.0, 2020-05-28

Added

  • Test coverage.

Edited

  • Updated source documentation.

  • Updated Gem Specification's email, summary, description, homepage, changelog URI, and dependencies.

  • Rewrote README.md.

Fixed

v3.0.0, 2020-04-09

Added

  • YARDocumentation.

  • GNU General Public License, Version 3.

  • A .yardopts file.

Edited

  • version.rb.

  • Gem Specification. Rewrote.

  • Copyright statements.

  • node_error_library_test.rb format.

Fixed

  • console bug.

  • README.md Installation and Documentation links.

v2.0.0, 2020-03-18

Added

  • Project.

  • Configuration files.

  • Documentation files.

  • Tests.

Edited

Fixed

Installation

Rubygems hosts the node_error package. Declare the package in the project's Gemfile, or, in the Gem Specification file:

Gemfile
Gem Specification
Gemfile
Gemfile
gem 'node_error', '~> 4'
Gem Specification
gem_name.gemspec
Gem::Specification.new do |spec|
# ...
# Development dependency.
spec.add_development_dependency 'node_error', '~> 4'
# Runtime dependency.
spec.add_runtime_dependency 'node_error', '~> 4'
# ...
end

Then, download and install the package:

$ bundle exec install

Bundler downloads and installs the package in the appropriate context.

require

Installation complete, insert require 'node_error_library' in a relevant file.