Packages

NodeSubscription packages.

Interface

Package

Version

node_subscription_int

0.1.0

Requirements

  • Ruby, v.2.6.5v. \geq 2.6.5

Dependencies

Development

Runtime

Changelog

v0.1.0, 2020-05-12
v0.1.0, 2020-05-12

Added

  • version.rb.

  • Gem Specification.

  • README.md.

  • 'self.instance()', 'publisher(p = nil)', 'update_subscribers(publisher = nil)', 'add_publisher(p = nil)', 'add_subscriber(p = nil, s = nil)', 'feeds()', 'feed(p = nil)', 'feeds=(s = Set[])', 'kind_factory(s = nil)', 'initialize()', and 'self.new()'.

  • Test coverage.

Edited

Fixed

Installation

Rubygems hosts the node_subscription_int package. Declare the dependency attribute in the Gem Specification file, or declare the gem in the project's Gemfile:

Gemfile
Gem Specification
Gemfile
Gemfile
gem 'node_subscription_int', '~> 0'
Gem Specification
gem_name.gemspec
Gem::Specification.new do |spec|
# ...
spec.add_development_dependency 'node_subscription_int', '~> 0'
# Or
spec.add_runtime_dependency 'node_subscription_int', '~> 0'
# ...
end

Then, download and install the package.

$ bundle exec install

Bundler downloads and installs the package in the appropriate context.

require

Installation complete, insert require 'node_subscription_int' in the relevant file.

Implementation

Package

Version

node_subscription_impl

1.0.0

Requirements

  • Ruby, v.2.6.5v. \geq 2.6.5

Dependencies

Development

Runtime

Changelog

v1.0.0, 2020-05-13
v0.1.0, 2020-05-13
v1.0.0, 2020-05-13

Added

Edited

Fixed

  • Circular subscription_impl dependency.

v0.1.0, 2020-05-13

Added

  • version.rb.

  • Gem Specification.

  • README.md.

  • 'NodeSubscription.instance()', 'publisher(p = nil)', 'update_subscribers(p = nil)', 'add_publisher(p = nil)', 'add_subscriber(p = nil, s = nil)', 'feeds()', 'feed(p = nil)', 'feeds=(s = nil)', 'kind_factory(s = nil)', 'initialize()', 'NodeSubscription.instance=(s = nil)', and 'NodeSubscription.new()'.

  • Test coverage.

Edited

Fixed

Installation

Rubygems hosts the node_subscription_impl package. Declare the dependency attribute in the Gem Specification file, or declare the gem in the project's Gemfile:

Gemfile
Gem Specification
Gemfile
Gemfile
gem 'node_subscription_impl', '~> 1'
Gem Specification
gem_name.gemspec
Gem::Specification.new do |spec|
# ...
spec.add_development_dependency 'node_subscription_impl', '~> 1'
# Or
spec.add_runtime_dependency 'node_subscription_impl', '~> 1'
# ...
end

Then, download and install the package.

$ bundle exec install

Bundler downloads and installs the package in the appropriate context.

require

Installation complete, insert require 'node_subscription_impl' in the relevant file.

Library

Package

Version

node_subscription

0.1.0

Requirements

  • Ruby, v.2.6.5v. \geq 2.6.5

Dependencies

Development

  • bundler, v.2.1v. \geq 2.1

Runtime

Changelog

v0.1.0, 2020-05-13
v0.1.0, 2020-05-13

Added

  • version.rb.

  • Gem Specification.

  • README.md.

  • node_subscription_int, node_subscription_impl, and subscription_comp.

  • File tests.

  • Dependencies.

Edited

  • Deleted Travis CI deployment settings.

Fixed

Installation

Rubygems hosts the node_subscription package. Declare the dependency attribute in the Gem Specification file, or declare the gem in the project's Gemfile:

Gemfile
Gem Specification
Gemfile
Gemfile
gem 'node_subscription', '~> 0'
Gem Specification
gem_name.gemspec
Gem::Specification.new do |spec|
# ...
spec.add_development_dependency 'node_subscription', '~> 0'
# Or
spec.add_runtime_dependency 'node_subscription', '~> 0'
# ...
end

Then, download and install the package.

$ bundle exec install

Bundler downloads and installs the package in the appropriate context.

require

Installation complete, insert require 'node_subscription' in the relevant file.